
How to Create Canyon Topos Using Inkscape 
 

By Michael Dallin 
 
Canyon Topos are a handy way to describe a canyon descent in a short space.  They are also useful for 
people who can not read a route description due to language differences.  While nobody has come up with a 
standard set of symbols, most topos are designed in a similar fashion. 
 
This is a tutorial to create a basic canyoning topo using Inkscape.  Inkscape is an open source vector graphics 
package.  You can download it for free from  http://www.inkscape.org/.  They have Windows, Mac and 
Linux versions available.  For this tutorial I am using the Windows version; directions may differ slightly for 
the Mac and Linux version. 
 
I also use a basic library of prepared graphics to save time.  You can download the latest from 
http://coloradocanyons.org/topos/CanyonTopoSymbols.zip 
 
I assume you have basic knowledge of Inkscape.  If not, Inkscape comes with a number of tutorials – it will 
help to familiarize yourself with the various controls and tools.  In particular you want to familiarize yourself 

with the Bezier Curves Tool ( ) and the Path Nodes Tool ( ).  For example, you should easily be able 
to draw several straight lines using the Bezier Curves tool, and then use the Path Nodes tool to add new path 
nodes, delete line segments between nodes, and turn straight lines between nodes into curves. 
 
 
Step 1:  Set Up Inkscape 
 
Start up Inkscape.  You will get a blank canvas to work with.  The first thing I like to do is zoom it to fit in 

the window by pressing this:  . 
 
You also need to set up the defaults for this new file.  Select File->Document Properties…  Choose if you 
want portrait or landscape, and if need be the canvas size. 
 
Next click the Grids/Guide tab.  I like to have gridlines while I work, so I check the Show Grid box.  The 
grid lines are especially nice to give scale to your topo.  For example, for rappels, I usually use one box equal 
to 10’. 
 
Finally click the Snap tab.  You can experiment here to see what settings you like best.  I like to check “Snap 
nodes to grid” under the Grid Snapping section.  This lets you easily draw vertical and horizontal lines and 
know they are truly vertical or horizontal.  Unfortunately you can’t “gently nudge” a path node while this is 
set, so usually after I have drawn my basic canyon I’ll go back and uncheck this. 
 
When you are done, close the Document Properties dialog. 
 
 
 



Step 2:  Draw an Outline of Your Canyon 
 
Using the Bezier Curve tool, draw an outline of your canyon.  Try to use the Bezier Curve tool to only draw 
straight lines at this point.  Don’t draw in pools yet.  Once you have drawn your canyon, select it and select 
the Path Nodes tool so that you can see all of the path nodes.  Move, tweak, resize them until you get your 
canyon with the scale you want.  Again, try to avoid making curves at this point, and don’t make any pools.  
Here is my example canyon, the Quartzite Corridor in Colorado: 
 

 
 
It’s not much to look at yet, but this is the basic shape of the topo. 
 
Tip:  You can make the line thicker if you want: right click on the line and select Fill and Stroke.  Click the 
Stroke Style tab and change the line thickness as you wish.  You can also change the line color by clicking 
the Stroke Paint tab. 
 
Tip:  If you don’t like the 90 degree angles, or if you want to create a “stylized” representation of your 
canyon, select the line with the Path Nodes tool, then select Path->Simplify.  Be warned that this can have 
some crazy effects (remember that Ctrl-Z is the undo function).  You will likely have to add path nodes and 
move nodes around to get the layout that you want, but this can add some flair to your topo.  If you want to 
do this, this is the best time to do it before we start adding things. 
 



 
Step 3:  Add Some Pools 
 
The Quartzite Corridor has a few swims, so lets add some pools in.  To do this we want to import the Pool 
graphic from my prepared graphics library.  Select File->Import, point to the folder with the prepared 
graphics, select Pool.SVG and click Open.  The pool graphic will appear, but you will probably notice that it 

takes up a large chunk of your page.  The first thing we will want to do is resize it.  Click the Select Tool  
and select it (if it imported on top of your canyon outline, you can drag it to an empty space).  When you 
select it, notice the various arrows in the corners of the selection box around it.  Click and drag these arrows 
to resize it how you want (you can also use these arrows to shrink it, stretch it, make it deeper etc).  Then, 
move it to the area of your canyon outline where you want to place it (this is where the Snap To Grid 
property comes in handy): 
 

 
 
 
 
Advanced Tip:  If you still don’t like the shape of the pool, you can select it with the Path Node tool, add 
new nodes, move them around, change the angle of the curve etc. 
 
The Quartzite Corridor has a second pool that has a potentially dangerous hydraulic.  So, let’s import the file 
from the graphics library called poolhydraulic.svg.  Follow the same directions to resize it and place it where 
you want on the canyon outline.  However, let’s zoom in on it.  Notice that the pool itself lies slightly above 
our canyon outline: 
 



 
 
This is because I have Snap To Grid checked.  To fix it, select File->Document Properties…, click the Snap 
tab, and uncheck both Snap Nodes To Grid and Snap Bounding Box To Grid (you can recheck them after 
you fix the pool).  You should then be able to move the pool around freely and place it in a better spot: 
 

 
 
In addition, you may want to remove the black line across the top of the pool.  This line is part of your 
canyon outline.  To remove it, select the Path Node tool, and click on your canyon outline.  Notice the path 
nodes on the sides of the pool (if you do not have path nodes on the sides of the pool, double click on each 
side of the pool on the canyon outline to create nodes there): 
 

 
 



Select both of the nodes.  To do this, click on one of them (it will change color), then hold down the shift key 

and click the other.  Then, click the Split Path Between Two Non-Endpoint Nodes button:  .  This will 
remove the line.  You may have to reposition or stretch the pool to close any gaps created: 
 

 
 
 
 
Step 4:  Adding Rocks, Logs and Trees 
 
Rocks and Logs (and other symbols for that matter) are added the same way as pools, except you likely 
won’t remove any lines from the canyon outline.  To add a log, import the file called log2.svg and resize it 
how you like and place it on your topo: 
 

 
 
This log represents and anchor a canyoner might use.  It looks funny standing on end though, so let’s rotate 
it.  Click the Select tool, and select it.  Notice the arrows appearing around the bounding box.  Click the log 
again and the arrows will change.  The corner arrows will become curved arrows.  Click on one of the curved 
arrows and move the mouse around.  This will rotate the log.  When it is rotated how you like, click on it 
again to get the resize arrows back.  Resize the log and move it to your desired location: 
 



 
 
Rocks are added the same way.  You can change the shape of the rocks though.  Import them, resize them 
and place them on your topo.  Then select the Path Nodes tool and click on a rock.  You can then click and 
drag the various nodes around to change the shape as desired: 
 

 
 
 
Trees are added the same way as rocks and logs: 
 

 
 
This looks good, but we want the trunk to match the topography of our canyon outline, to show that the tree 
is perched on a steep slope.  We change this by clicking the Path Nodes tool, selecting the tree and moving 
the nodes in the trunk down to match the canyon outline: 
 



 
 
 
Step 5:  Add Unremarkable Narrows and a Bridge 
 
Unremarkable Narrows is a stretch of canyon that isn’t very interesting.  Instead of drawing all of the 
uninteresting areas, we use the Unremarkable Narrows symbol to show that we are abbreviating that section.  
Using import, add the file unremarkeablenarrows.svg to your canyon, and resize it to your liking.  Notice that 
the symbol has a dashed line through it.  If we were to put this over our canyon outline, the outline would 
cover up the dashed line: 
 

 
 
This may be fine for you, but if you want the dashed line to show, click the Path Nodes tool and select your 
canyon outline.  Create two nodes on either side of the unremarkable narrows symbol by doubleclicking at 
those spots.  Then, select the nodes and remove the line between them, just as you did with the line over the 
pools above: 
 

 
 
If you have more than one spot with unremarkable narrows, you don’t have to keep reimporting and resizing 
the symbol.  Instead, right click on it, select Copy, then Paste it somewhere and move it to where you like. 
 
At the end of the Quartzite Corridor, the stream runs under a highway bridge.  We import that graphic as 
well, rotate it and resize it, and we can remove the canyon outline following the steps above: 
 



 
 
 
 
Step 6:  Rappel Arrows 
 
Topo authors use a variety of arrows to symbolize rappels, downclimbs, jumps and slides.  Many topo 
authors use the same arrow (just a generic one) to represent rappels, downclimbs and jumps, while others 
(like the ACA) uses unique arrows for each of these.  I find it handy to have the Snap Nodes To Grid 
function checked in Document Properties when creating arrows to ensure they are vertical. 
 
For a generic arrow, first draw a straight line.  The easiest way to draw a line is to use the Bezier Curve tool.  
Click the first point, then move the mouse to where you want the other endpoint (no need to hold the mouse 
button down when doing this).  Then double-click at the endpoint, and a line will be drawn.  Now you add an 
arrow head.  Right click on the line and select Fill and Stroke.  In the Fill and Stroke dialog, click the Stroke 
Styles tab.  In the End Markers drop down, select your desired arrow 
 

 
 
Just as with the Unremarkable Narrows symbol, you can right-click and copy, and then paste another arrow 
in another location to save time.  Move the new arrow where you want it, select the Path Nodes tool and drag 
the nodes to resize the arrow how you want. 
 
Next is the “slides” arrow.  First, draw an arrow where you want to put the slide pointing diagonally 
downward: 
 

 



Next, select the Path Nodes tool and click on the arrow.  This time, instead of clicking and dragging the path 
nodes of the arrow, click and drag the arrow itself.  The arrow itself should bend.  However, the arrowhead 
may bend in bizarre ways.  You can rotate the head by clicking on it and dragging with the Path Nodes tool: 
 

 
 
The ACA recommends three different arrows to represent rappels in water, jumps and downclimbs.  First, 
jumps.  Draw the following using the Bezier Curve tool, and then put an arrow head on the end of it like 
above: 
 

 
 
Select the Path Nodes tool, select the arrow, and drag the midpoint of the horizontal line upward to make a 
curve (turn off Snap Nodes To Grid for fine tuning): 
 

 
 
Next is the Downclimb arrow.  This is simply a jagged Bezier Curve line (all of them straight) with an arrow 
at the end: 
 



 
 
And finally we have the Rappeling Through Water symbol.  Draw a straight line arrow pointing down, select 
the Path Nodes tool, and add a node about a third of the way down the arrow, and a second two thirds of the 
way down: 
 

 
 
With the Path Nodes tool still selected, click on the midpoint of the arrow and drag it to the right (turn off 
snap nodes to grid to fine tune): 
 

 
 
 
Step 7:  Text 
 
Topo authors put a variety of text on their topos, though the text used tends to differ from culture to culture 
(if not author to author).  It is best to define the standard you want to follow, and then stick to it.  You can 
find a companion document at http://coloradocanyons.org that describes common symbols and text used by 
topo authors. 
 

To add text, select the Text tool .  You can adjust the font and size of your text in the toolbar.  Click 
where you want text, and type away. 



 
Note that often some letters are also used as symbols.  For example, it is very common to represent a bolt 
using an “x”.  For example, you might see something like this that shows a 30 foot rappel from bolts: 
 

 
 
 
You may also see something like this to show a fixed line between bolts, or a traverse that is protected with 
bolts, followed by a rappel down: 
 

 
 
 
Step 8:  Finishing Touches 
 
At this point you should be able to add other symbols and text to fill things out how you like.  You can also 
try some other features:  for example, you can use File->Import to import photographs of your canyon. 
 
You can also try playing around with Simplify at this point to get some interesting effects.  First, select your 
canyon outline using the Path Nodes tool, then select Path->Simplify.  This will round many of the corners.  
It might not be to your taste, but you might be surprised: 
 

 
 
Note that you can select Simplify multiple times for a more pronounced and abstract effect.  Also note the 

various toolbar buttons active when you select the Path Node Tool:    These commands 
will create curved areas only where you have selected nodes, for a localized effect. 
 
You can also add effects like the rim of the canyon.  To do this, I simply use the free hand draw tool to draw 
the rim in, and then select the line(s) with the Path Node tool.  Then select Path->Simplify (or press Control-



L), and keep invoking the Simplify command until you get the effect you want (and remember, Ctrl-Z will 
Undo!) 
 
 
 
The Finished Product: 
 

 


